CrowPI2 not working anymore



  • @Pearl, No the ACT LED Green does not repeat. I tried the PI-4B 8GB with a monitor and without microSD card. Just the Red Led is burning. No test screen or other messages appeared. I ordered a new PI as I have no response for more than 3 weeks from Elecrow.

  • edited August 2021

    @Celleke This does sound like either the bootloader is corrupted or your Pi-4B/8G is damaged. I don’t know whether you’ve tried to re-flash the boot EEPROM. If you like to give it a try, follow the steps below


    1. Your working Pi-4B/4G running Raspberry Pi OS or the latest CrowPi2 OS
    2. A spare microSD card (any size is fine)
    3. A USB to microSD Card Adapter
    4. Raspberry Pi Imager app, should be already installed with RasPi OS or CrowPi2 OS.


    1. Insert a spare microSD card with adapter into an available USB port of the Pi-4B/4G. If a pop-up window appears, just click cancel to dismiss it.
    2. Launch Raspberry Pi Imager.
    3. Click the CHOOSE OS button.
    4. Under Operating System, select Misc utility images.
    5. Select Bootloader.
    6. Select a boot-mode i.e. SD (recommended), USB or Network.
    7. Click the CHOOSE STORAGE button.
    8. Select the spare SD card under Storage. (Note: The contents will get overwritten!)
    9. Click the WRITE button when ready.
    10. After completion, eject the SD card.
    11. Connect your Pi-4B/8G to a HDMI monitor and boot it with the new image and wait for at least 10 seconds.
    12. The ACT LED (Green) will blink with a steady pattern and the HDMI display will be green on success.
    13. Power off the Pi-4B/8G and remove the boot EEPROM flash SD card.
    14. Insert a standard system SD card (RasPi OS or CrowPi2 OS) and reboot.

    If all goes well and your Pi-4B/8G was not damaged, it should boot (Hopefully!!). 


  • edited August 2021

    @Pearl , many thanks for your support. Followed your instructions but nothing happened. No Green Led flashing.

    Strange thing is that I tried to boot the 4B 8gb with a Raspberry OS card and the green Led was flashing 4 times but nothing else happened. Turned power off. Waited 30 seconds and tried booting again. Now the green led was not flashing at all.

    So do you think the PI is really dead?


  • edited August 2021

    @Celleke At step 12, does the ACT LED (Green) keeps blinking and the connected HDMI Display becomes Green or Red? If the HDMI Display isn't showing Green, then the flashing of the Boot EEPROM has failed. Try repeat from step 11 again.

    Also, does the same Raspberrt Pi OS card works in your Pi4B-4G? If yes, please open a new Terminal window and type the command

    uname -a

    and post the displayed output.

  • @Pearl No. At step 12 there is no Led blinking Green at all neither is the display. Tried couple of times from step 11 but no success. Do you think the board is dead?

  • @Celleke In that case, I'm afraid, the board is certified.

  • @Celleke Forget to confirm the Power Supply that you use to power the Pi. Is it an offical Raspberry Pi Power Supply with a 5.1V 3A output rating?

    Or you are using a mobile phone charger.

  • @Celleke That power supply is fine. So, no power related issue in your case. Because Raspberry Pi is really picky and requires a good quality power supply with a stable +5V under load.

  • So the board is dead? sniff sniff

Sign In or Register to comment.