7 inch screen works fine with a 64gb sd card but not with a 125 gb card

I have an Elecrow 7 inch 1024 x 600 screen. It works fine on a Raspberry Pi 4b with 4 gb RAM with a 64gb SD card in it, but will not start if I insert a 125gb card. Just says 'no signal'

I duplicated exactly the config.txt changes on printed instructions which worked for the 64gb card, but it still doesn't work.

Is there some tweak required to config for 125 gb cards

Doesn't work either on another Raspberry pi 4b with 2 gb RAM


  • Hello @SteveHodge ,

    The screen displays content by connecting to the Raspberry Pi motherboard and receiving image signals.

    Normally, the memory size of the SD card does not affect the use of the screen. Please connect Raspberry Pi to another screen with the 125GB SD card inserted and see if it can start normally?

  • I have tried another raspberry pi 4b and a standard HDMI monitor. With a 125gb card and loading both a current and a legacy raspberry pi system the raspberry pi works fine with the standard monitor, but as soon as I modify the config.txt file as instructed in your instructions I am back to a blank screen

  • Hello @SteveHodge ,

    I checked the instructions. The sentence "hdmi_mode=1" should be deleted.

    Really sorry for the misleading.

  • Thanks for this

    Partial success

    With a 125 gb SD card loaded with a legacy (ie May 2023 Raspian OS) and your revised code in the config.txt file the system will fire up a regular hdmi screen as normal but not the elecrow 7 inch screen. Curiously however if I start up the pi with elecrow screen connected to the second hdmi port it will fire up, but the overscan seems to have gone wrong - can't see the top left corner of the screen and the background picture is the one that comes with the download of the OS. Curiouser still if I then hot switch the hdmi feed from the second port to the first port the Elecrow screen comes up as normal (sceen size correct) and also with a different backgroundpicture, one which I selected from the menu ina previous attempt

    I can get nothing on the elecrow screen with the SD card loaded with the same legacy OS but which I have allowed Debian to update through terminal and apt-get. And if I flash the latest OS I also get nothing.

    So it seems as though there are two problems. One with the latest OS (no doubt the upgrade moved my second card over to the latest OS), and a second one as yet undetermined. I am wonder if it is something to do with the quality of the HDMI cable or the connectors. The elecrow screen seems to be almost working properly- the screen flashes quite a few times but does not light up, while the success of the hotswitch trick seems to suggest some sort of hardware issue to me

  • When you ran the May 2023 Raspian OS, did you modify





  • Yes did all this. It is working fine now. Many thanks. I changed the hdmi cable to a better one. I think the adapter and cable that came with the screen was a bit substandard. It eventually broke on me

    Never did get the screen working on Debian Bookworm though, only Debian BullsEye seems to work

  • Is this working now on BookWorm? I have it working on Buster on another Pi, thought it would be a simple matter of updating the config.txt file....Doens't work. Any suggestions when this might be available for Bookworm please?



  • Correction to my last post... I have it working on Bullseye...but not Bookworm :-(

Sign In or Register to comment.