edited November 7 in Elecrow Display

Hello everyone. I need help with a 7-inch HMI display. I've tried many things, but I'm facing various issues. Sometimes the code doesn't load, and sometimes it gives a code error. To test if the code is loading, I loaded a blank page, and the demo on the screen disappeared. It said that the 'lv_conf.h' file was missing, so I found and added it. I tried to load the 'Hello World' sample code, but it gave an error because there was no setup and loop. I added them in an empty way and transferred the code, but the screen still didn't work. I used to use an ESP32 before, and this is the first time I'm using this display.

In short, I've tried many things and installed and uninstalled a lot of stuff. I'm at a negative point, maybe not even at zero. I had progressed according to the videos as well. Is there anyone who can help me through Discord? Or if someone understands my situation and wants me to explain things as if to a complete beginner, I can share my issues.



  • Is there anyone who has experience using this product properly? I have a few silly questions, and even if they answer those, I might find my way. It's a niche product in terms of content. Why haven't they sent this product to YouTubers?"

  • I'm putting a halt to working on the product until I get a response. I'm about to lose my mind. I've followed the things in the video or the blog, but I think I must have missed something. Please help me urgently.

  • 40 views but 0 response ? how :)

  • Hello @ysf_mrmr

    Please check whether the Arduino_GFX library is installed. In addition, please check whether the version of esp32 package is 2.0.3

  • I already downloaded arduino_gfx and the Esp32 version is also correct. Do you have a Discord group? I still haven't been able to upload and use the code properly.

  • In demo mode, I get the error I posted in another post. I can't even load the demo code properly. @Elecrow

  • @Elecrow ı dont use demo code :/ pls helppp. I do exactly what you did in the video, but it doesn't work.

Sign In or Register to comment.