Touch not working on 7" 1024x600 Display

I purchased the 7" display from Elecrow and I am having issues getting the touch functionality to work. I previously had the 5" elecrow display running on the same Raspberry Pi (it's an industrial version called RevPi) and the touch was working fine. Since this is an industrial I cannot reimage it with a stock version of the image and used the manual setup method for the display. Is there something additional that I need to add in order to get the touch functionality to work?


  • I tried plugging the display into another raspberry pi and a windows machine, it seems like the touch interface is just not working on this particular display. Is there any way to enable it or something else for me to check?
  • Solved it. It was a cable issue. Not all micro USB cables will work for enabling the touch interface to work properly and only supply power to the screen.
  • I'm seeing a similar issue. I've been using the cable that came with the display, and I've also swapped out to various other USB cables, but I'm not sure if maybe all of them are 'bad' cables for the job. Is there a way to test if the cable I'm using is sufficient? For example, one of the ones I'm using is for my mouse. It seems that cable would be able to send data since it's sending the mouse movements, right? Were you using the cable that came with your display originally?
Sign In or Register to comment.